Spartan 5.1 User's Guide

Chapter 7 (Cont'd): The Build Menu


Section 7.2: Conformer Search

THIS SECTION IS UNDER CONSTRUCTION!!!

One of the greatest challenges in applications of quantitative molecular mechanics and molecular orbital calculations is dealing with conformationally-flexible molecules. Detailed conformation dictates overall molecular size and shape, and exerts major influence on molecular properties and chemical reactivity and selectivity.

Assignment of preferred conformation is not simple because the number of possible conformers can be very large. This is illustrated for the case of conformer generation via a simple systematic search technique, and limited to single bonds not incorporated into rings. Given N single bonds and a step of 360°/M, the number of conformers which need to be considered in such a search is MN. For three single bonds and a step of 120° (M=3), this leads to 27 conformers; for five single bonds with the same step, 243 conformers need to be considered. For each conformer considered, it is necessary to perform energy minimization in order to relieve severe steric interactions. Also, steps smaller than 120° may be required in order to avoid missing conformers. Hence, the problem is of considerable computational complexity, even for relatively simple flexible acyclic molecules. It becomes even more complex when flexible rings are involved.

When a conformation search is performed in SPARTAN, bonds are marked for rotation and rings for "rotation" automatically without user intervention. A search method ("Systematic" or "Monte-Carlo" is automatically chosen as that which leads to the smaller number of "moves". Bond and ring selections can be altered, the extent of bond rotations (3-fold, 4-fold, etc.) adjusted and the search method changed by selecting Conformer Search from the Build menu--resulting in the following dialog.

Clicking on a selected bond (identified by a yellow cylinder) displays a text box to the right of "Field Rotation:", the contents of which can be altered. Double clicking on a selected bond, deselects it. Double clicking on a bond which is not selected, selects it and leads to the "Field Rotation:" text box. Double clicking on a selected atom in a ring (identified by a yellow circle around the atom) deselects it. Double clicking on an unselected atom selects it for "rotation". Four, five and six-membered rings are treated differently than larger (seven-membered and larger) rings. By default, four and five-membered rings are not selected and six-membered rings are designated as leading only to two chair conformers (and not to any half chair conformers). This is indicated by the fact that only two ring atoms (directly across from one another), are selected. Default settings for four, five and six-membered rings may be overridden by selecting the appropriate ring atoms for "rotation".

Using either default or user-specified settings, two different modes of conformer search are available "single" or "multiple". The former attempts to locate the lowest-energy (global) conformer, while the latter provides a small set of low-energy conformers (including the lowest-energy conformer). Selection of "single" or "multiple" is made under the Task menu inside the individual calculation dialogs (Ab Initio, Density Functional, Semi-Empirical or Mechanics under the Setup menu). Except for mechanics, a warning is provided following selection of either "Conformer Search (single)" or "Conformer Search (multiple)" indicating that the requested calculation is likely to be very time consuming.

Conformation searching may be interrupted at any time (Kill from the Monitor) after which it may be restarted.

  1. Options

    Options are available to further specify conformation searching. These are directly input into the Options box. A complete listing of keywords is provided below, starting with keywords which pertain to all methods and then providing keywords specific to the individual searching methods. Keywords may be either words or expressions. Keyword=N indicates an integer argument, keyword=C indicates a character argument, and keyword=F indicates a floating-point argument.


General
CONFANAL Signal a conformation analysis is to be performed.

DTHRESH = F Specify the maximum difference in distances between two conformers that are considered as duplicates (default=0.25Å).

DUPLICHECK = C Specify methods for duplicate-structure checking.

NONE no checking is performed
P

permuted angle checking
R

reversed angle checking
M

reflected angle checking
(default is DUPLCHECK=PRM)

TEMPERATURE=F Specify the temperature for Boltzmann populations (Centigrade).


Systematic
ENFORCE Treat the value of each open-chain dihedral as a constraint.


Osawa
CISTRANS Permit cis/trans flip during structure generation.

DTHRESH = F Specify the maximum difference in distances between two conformers that are considered as duplicates (default=0.25Å).

RINGS=C Specify the ring conformation generation method:

NONE no rings are generated
FLAP

use corner flapping
FLIP

use bond flipping
FLAP+FLIP

use both methods (default)
FAST Pre-check new structures prior to optimization.

NOREMIN Do not reexamine the conformers found in the search (default for quantum mechanical calculations).

REMIN Reminimize the conformers found in the search and recheck for duplication (default for molecular mechanics calculations).

ENFORCE Treat the value of each open-chain dihedral as a constraint.

HTORS Permit dihedrals involving hydrogen atoms.

INITIALE = F Specify the maximum-energy threshold for conformer acceptance; molecular mechanics only (default=10,000 kcal/mol).

MAXCONF = N Specify maximum number of conformations to return (default=50, limit=1000).

MAXCONF = N Specify maximum number of conformations to return (default=50, limit=1000).

MINPOP=C,
MINPOP=F
Specify the minimum Boltzmann population cutoff (default=0.1).

0.N return structures with pop above 0.N.
ALL

return all structures.
EMAX = F Specify the upper-limit on the energy (default=number of atoms/2).

FMOVE = F Specify the corner-flapping displacement in Å (default=0.0, 0.01 to 0.15 reasonable).

EWIN = F Specify the energy window for conformer matching (default=number of atoms/20).

DWIN = F Specify the dihedral window for conformer matching in degrees (default=10.0°).

SELPOP=C,
SELPOP=F
Specify the Boltzman population threshold for structure. Reuse (default=0.1).

0.N reuse structure if pop above 0.N.
ALL

reuse all structures.
OWINDOW = F Specify the dihedral window for olefin cis/trans checking in degrees (default=40.0°).

DEBUG Print details of each structure optimization.

EMIN = F Specify the minimum-energy threshold for conformer acceptance, i.e., a conformer with an energy lower than Ebest - EMIN will be discarded (default=50 kcal/mol).

COMPLETE This keyword forces the following options:

MINPOP=ALL

SELPOP=ALL

DUPLCHECK=NONE

Monte Carlo
POPSIZE = N Specify the size of the population. This is the number of conformers that will be involved in the search (default=35).

MAXGEN = N Specify the maximum number of generations or cycles in the search of the conformation space (default=100).

RAND Use only fully randomized starting structure(s). Otherwise the input conformation will be used.

MINBOND = N Specify the minimum number of bonds that will be rotated during a Monte Carlo cycle (default=1).

MAXBOND = N Specify the maximum number of bonds that will be rotated during a Monte Carlo cycle (default=1)..


Genetic Algorithm
POPSIZE = N Specify the size of the population. This is the number of conformers that will be involved in the search (default=50).

MAXGEN = N Specify the maximum number of generations or cycles in the search of the conformation space (default=100).

SWAP = F Specify the rate at which selected torsion angles will be swapped rather than averaged between two parents during breeding (default=1.0).

BREED = F Specify the rate at which parents will be chosen for breeding (default=0.7).

MUTFREQ = F Specify the rate at which members of the population will be chosen for random mutation (default=0.01).

MUTLEVEL = F Specify the rate at which selected dihedrals will be randomly altered (default=0.05).

MAXDEV = F Specify the maximum average deviation in the population to continue evolving (default=1.0).

RAND Use only fully randomized starting structure(s). Otherwise the input conformation will be used.


The Conformer Search dialog is exited by selecting Quit from the File menu.


Section 7.2.1: Conformer Search Functionality

As in the builder dialogs, the user can rotate, translate or scale the molecule using the mouse. Bond rotation and stretching are not permitted.

Conformation searching may occur in the presence of any constraints which have been introduced in the builder dialogs. The selection of whether or not to actually use constraints is made in the setup dialog for molecular mechanics, semi-empirical, density functional or ab initio calculations. Discussion is provided in Sections 8.2-8.5.


Section 7.2.2: Menus in the Conformer Search Dialog

Other functions are accessed by way of menus from the menu bar at the top of the Conformer Search dialog.


Section 7.2.2.1: Logo

Selection results in display of the following menu:

About SPARTAN
Colors
Preferences

About Spartan

Colors

Preferences

These functions are the same as those already described in Sections 3.1 and 3.3, although some functions do not apply to operations in the Conformer Search dialog.


Section 7.2.2.2: File

Selection results in display of the following menu:

Save
Save As

Quit Ctrl+Q

Save

Saves a previously named file. If Save is selected for an unnamed (not previously saved) molecule, it behaves as Save As (see Section 4.5). The screen is not cleared, and the Conformer Search dialog is not exited.

Save As

This is the same function already described in Section 4.5. The screen is not cleared, and the Conformer Search dialog is not exited.

Quit

Exits the conformer search dialog.


Section 7.2.2.3: Edit

Selection results in display of the following menu:

Clear

Clear

Clears the existing structure from the Conformer Search screen. A warning message is first presented to the user.


Section 7.2.2.4: Geometry

Selection results in display of the following menu:

Distance
Angle
Dihedral

Define Point
Define Plane

Report Symmetry

Distance

Angle

Dihedral

Define Point

Define Plane

Report Symmetry

These are the same functions already described in Sections 6.1 to 6.3 and 6.8, 6.9 and 6.12, respectively.


Section 7.2.2.5: Help

Selection results in display of the following menu:

Conformer Search Overview
Conformer Search Options

Conformer Search Overview

Describes the operation of Spartan's Conformer Search dialog.

Conformer Search Options

Lists options available for the control of conformation searching. These apply to molecular mechanics, semi-empirical and ab initio molecular orbital calculations, and density functional calculations. This listing is also accessible from the Help menu in the main window.


Section 7.3: Transition Search

Location of transition states is still perceived as a very difficult problem in practical applications of quantum chemical methods. Certainly this task is not yet as routine as that of finding minimum-energy (equilibrium) structures. One reason for the difficulty is the numerical problem involved in finding a stationary point on a multidimensional potential energy surface which is a minimum in all dimensions, except for one direction (the "reaction coordinate"), which is a maximum. Even more serious, is an overall lack of knowledge of what transition states "look like". Whereas chemists can easily construct accurate representations of stable molecules, and thereby provide very good starting points for structure optimizations, they lack the experience to do the same for transition states. The situation will change with time, as more and more reactions are investigated theoretically. No doubt, systematics in transition state structures will be uncovered. A third problem is that the same quantum mechanical methods which have proven to be suitable in descriptions of stable species may not be adequate for transition states, i.e., species in which bonds are partially formed or broken.

The procedure built into Spartan for guessing a transition state is based on the Linear Synchronous Transit method, and provides a geometry intermediate between those of reactant and product molecules. There is a single parameter, indicating the relative weighting of reactant and product structures to be used in the construction (recall the Hammond postulate). This ranges from 0.0 (reactant structure) to 1.0 (product structure), the default value being chosen as 0.5. Such a procedure is directly applicable to intramolecular reactions, and as discussed in Section 7.3.3, may easily be extended to intermolecular processes.

Prior to selecting Transition Search under the Build menu, structures corresponding both to the reactant and to the product must be open on screen, and one of these structures (corresponding to the reactant) must be selected. In the case of a degenerate rearrangement, i.e., reactant and product are the same, only a single copy needs to be open. (Structures other than reactant and product open on screen have no effect on the guessing procedure.)

Selecting Transition Search results in the selected molecule being designated as the "reactant" and leads to a message in the menu bar.

Transition Search: Select a molecule to specify the product.

Clicking on a second molecule (or on the original molecule in the case of degenerate reaction) designates it as the product, and results in a split-screen display, with the reactant at the right and the product at the left.

Note that reactant and product must be isomers, i.e., contain the same number of each element. Attempts to enter the dialog with molecules which are not isomers will lead to an error message. Structural representations used in the transition search dialog are the same as those employed in builder and conformer search dialogs, atoms being designated by small balls and bonds by thin lines.

A button bar, immediately below the menu bar, accesses functions (Add Pair, Remove Pair, Show Pair, Generate and Clear) to assist in the generation of a guess transition state. These may also be accessed from the Edit menu (see Section 7.3.2.3). The bar also provides a message.

0 of X Atoms Paired

X is the number of atoms (which need to be paired) in the reactant and product molecules. The first number will be incremented by 1 each time an atom on one molecule is successfully paired with an atom on the other, until the number of atoms paired equals the total number of atoms.

Atom pairing is accomplished by first clicking on the ball designating an atom on one molecule, followed by clicking on the ball designating the atom on the second molecule to which the first atom is to be associated. Upon selection of the first atom of a pair, the associated ball will be colored gold; clicking on this atom a second time (without clicking on an atom in the second molecule) deselects it, returning the ball to its original color. Another atom (in either molecule) may then be selected. Upon selection of the remaining atom both balls will disappear. In addition, the counter at the bottom of the screen will be incremented by 1. Attempts to click in succession on two atoms on the same molecule, or to click on an atom on the second molecule of different type (atomic number) will result in a bell, signaling that pairing is not allowed. Try again. This procedure needs to be repeated until all atoms are associated. Following this, a transition-state guess is automatically generated and the original split-screen (showing reactant and product) is replaced by a single screen displaying the guess at the transition structure.

In addition, a dialog appears which allows the guess to be altered.

Weighing Factor is a measure of the extent to which the transition state guess resembles reactant or product. "0.0" is fully reactant-like and "1.0" is fully product-like. The default value (0.5) may be changed and a new transition state guess generated by clicking on Apply.

When the guess is satisfactory, the Transition Search dialog may be exited by selecting Quit from the File menu (see discussion below).


Section 7.3.1: Transition Search Functionality

As in the builder dialogs, either reactant or product molecules can be rotated, translated or scaled using the mouse. Bond rotation and stretching are not permitted.


Section 7.3.2: Menus in the Transition Search Dialog

Other functions are accessed by way of menus from the menu bar at the top of the transition search dialog.


Section 7.3.2.1: Logo

Selection results in display of the following menu:

About SPARTAN
Colors
Preferences

About Spartan

Colors

Preferences

These are the same functions already described in Sections 3.1 and 3.3, although some functions do not apply to operations in the Transition Search dialog.


Section 7.3.2.2: File

Selection results in display of the following menu:

Save
Save As

Quit Ctrl+Q

Save

Saves a previously named file. Save is activated only after a transition state guess has been formed from a reactant and product structure. The screen is not cleared, and the Transition Search dialog is not exited. If Save is selected for an unnamed (not previously saved) molecule, it behaves as Save As (see Section 4.5).

Save As

This is the same function already described in Section 4.5. Save As is activated only after a transition state guess has been formed from a reactant and product structure. The screen is not cleared, and the Transition Search dialog is not exited.

Quit

Exits the Transition Search dialog. Selection of Quit before atom pairing has been completed results in display of the following dialog.

Clicking on Quit exits the dialog with resulting loss of all pairing information. Clicking on Cancel returns to the Transition Search dialog with no action taken. Selection of Quit after all pairing has been completed and a transition-state guess has been generated (and modified as needed) leads to an on-screen dialog.

Clicking on Yes leads to the usual file browser and request for a name (associated with the transition state structure generated from reactant and product molecules). Clicking on No exits the dialog without saving the guess transition state which was generated. Clicking on Cancel returns to the screen which contains the transition state guess.


Section 7.3.2.3: Edit

Selection results in display of the following menu:

Remove Pair
Show Pair

Generate

Clear

Generate when both reactant and product molecules are on screen. Generate is available only after atom pairing has been completed.

Add Pair

Allows pairing of atoms between reactant and product. Add Pair is selected upon initial entry into the Transition Search dialog

Remove Pair

Allows removal of one or more atom pairs. Selection results in small solid balls being displayed for paired atoms on both reactant and product molecules, and a message appearing in the menu bar.

Remove Pair: Select an atom on either reactant or product.

Clicking on one of these balls (on either reactant or product) removes it as well as the ball representing the atom to which it is paired on the other molecule. The procedure may be repeated as necessary. Termination follows by selecting Add Pair, Show Pair or Clear from the button bar.

Show Pair

Shows atom pairs. Selection results in small solid balls being displayed for
paired atoms on both reactant and product molecules, and a message appearing in the menu bar.

Show Pair: Select an atom on either reactant or product.

Clicking on one of these balls (on either reactant or product) changes both its color and the color of the ball to which it is paired on the other molecule to gold. The procedure may be repeated as necessary. Termination follows by selecting Remove Pair, Generate or Clear from the button bar.

Generate

Returns to "generate mode" (following selection of Show Pair from the button bar).

Clear

Displays an on-screen dialog.

Clicking on Clear clears all information relating to transition state generation (atom pairing information and the guess transition state had one been generated), and returns to the display to that which appeared upon initial entry into the Transition Search dialog. Clicking on Cancel cancels the request.


Section 7.3.2.4: Geometry

Selection results in display of the following menu:

Distance
Angle
Dihedral

Define Point
Define Plane

Report Symmetry

Distance

Angle

Dihedral

Define Point

Define Plane

Report Symmetry

These are the same functions already described in Sections 6.1 to 6.3 and 6.8, 6.9 and 6.12, respectively.


Section 7.3.2.5: Help

Selection results in display of the following menu:

Transition Search Overview

Transition Search Overview

Describes the operation of Spartan's transition-state searching procedure.


Section 7.3.3: Treatment of Intermolecular Reactions

Description of a transition state in terms of a geometry intermediate between reactant and product geometries, while reasonable for intramolecular reactions, is not directly applicable to intermolecular processes, where either reactant or product (or both) consist of separated molecules. One solution is to replace the "separated molecules" by a "weak complex", for the purpose of providing a guess at the transition state. There are two ways to construct such a complex. The first is to build it as a "single molecule" using constrain functions (see Sections 6.5 to 6.7). The second is to position and orient the two product molecules on screen as to resemble such a complex, and then to merge them into a single molecule (Merge As under the File menu, see Section 4.6). 3D capability (see Section 2.8) is especially valuable for the latter.


Section 7.4: Vibration Sequence

Spartan allows animation of any graphical object (structural model, isosurface or contour) along a normal vibrational coordinate. Among other things, this feature allows changes in the electron distribution to be followed throughout a chemical reaction so as to assign bond making and breaking without reference to any preconceived ideas about bonding. It also allows examination of changes in
key molecular orbitals throughout a reaction, facilitating the construction of qualitative arguments.

Selection of Vibration Sequence under the Build menu is only possible following a normal-mode analysis (the menu entry is grayed out and inaccessible otherwise), and results in display of the following dialog.

Like the builder and conformer search dialogs, the display area is divided into two regions: a work area on the left for display and manipulation of vibrational motion, and a vibration sequence panel on the right. The latter contains a box which lists the normal-mode vibrational frequencies, and controls to vary the amplitude of the vibrational motion as well as the number of steps in the animation.

Upon entry into the dialog, whatever model was present on Spartan's main screen appears in the work area. This can be changed to whatever type of model is desired (Model menu inside the Vibration Sequence dialog). Selection of the desired vibrational mode occurs by clicking on the associated frequency in the vibration sequence panel. Amplitude and Frames control the amplitude and resolution of the vibration, respectively. Default values, 1.00 and 7, respectively, may be changed. A vibration sequence is generated by clicking on Generate Sequence, following which, a dialog appears in the work area.

Each frame in the list corresponds to a step "forward" or "backward" along the normal mode from the "equilibrium" position (the middle frame). Clicking on Animate inside this dialog results in display of the sequence of images in rapid succession. Clicking on and (Step keys) steps through the images one-by-one. In either case, the name of the frame currently displayed is given in the center of the dialog.

Animation of a different vibrational mode is accomplished by selecting a different frequency, followed by clicking again on Generate Sequence. Different amplitudes and resolution follow by entering new values for Amplitude and Frames, respectively, and clicking on Generate Sequence.


Section 7.4.1: Vibration Sequence Functionality

As in the builder dialogs, the molecule may be rotated, translated or scaled. Bond rotation and stretching are not permitted.


Section 7.4.2: Menus in the Vibration Sequence Dialog

Other functions are accessed by way of menus from the menu bar at the top of the Vibration Sequence dialog.


Section 7.4.2.1: Logo

Selection results in display of the following menu:

About SPARTAN
Colors
Preferences

About Spartan

Colors

Preferences

These are the same functions already described in Sections 3.1 and 3.3, although some functions do not apply to operations in the Vibration Sequence dialog.


Section 7.4.2.2: File

Selection results in display of the following menu:

Save
Save As

Quit Ctrl+Q

Save

Saves the entire set of frames generated in the Vibration Sequence dialog as a list. On first access, Save behaves as Save As (see Section 4.5) requiring that a name be supplied. Save does not result in the Vibration Sequence dialog being exited.

Save As

This is the same function already described in Section 4.5. This saves the entire set of frames generated in the Vibration Sequence dialog as a group under a user supplied name. Save As does not result in the Vibration Sequence dialog being exited.

Quit

Exits the Vibration Sequence dialog. If the sequence has not been saved, (using the Save or Save As functions above), Quit will lead to the usual file browser and request for a file name.


Section 7.4.2.3: Model

Selection results in display of the following menu:

Wire
Ball and Wire
Tube
Ball and Spoke
Space Filling

Hydrogens

Labels

Wire

Ball and Wire

Tube

Ball and Spoke

Space Filling

Hydrogens

Labels

These are the same functions previously described in Sections 5.1 to 5.5, and 5.7 and 5.8, respectively.


Section 7.4.2.4: Geometry

Selection results in display of the following menu:

Distance
Angle
Dihedral

Define Point
Define Plane

Report Symmetry

Distance

Angle

Dihedral

Define Point

Define Plane

Report Symmetry

These are the same functions previously described in Sections 6.1 to 6.3 and 6.8, 6.9 and 6.12, respectively.


Section 7.4.2.5: Help

Selection results in display of the following menu:

Vibration Sequence Overview

Vibration Sequence Overview

Describes the operation of Spartan's vibration sequence procedure.


Section 7.5: Coordinate Driving

Spartan's ability to easily handle entire collections of molecules finds use in constructing structure sequences, as for example might be used to depict a reaction pathway or examine the variation in energy as a function of dihedral angle. The present implementation is limited to one-dimensional sequences, where the sequence may be made up of one or more segments. Each segment is defined in terms of uniform (linear) increments to one or more geometrical variables (bond lengths, bond angles, dihedral angles).

Coordinate driving is accessed by selection of Coordinate Driving from the Build menu.

The dialog which results is divided into two regions, a work area on the left for selection of coordinates to be "driven" and a coordinate driving panel on the right. Menus provide additional functions. Upon first entry into the dialog, the Segment box will contain a "1", and the box underneath Constraints will be empty. Selection of one or more coordinates to be driven is made by first clicking on Drive Distance, Drive Angle or Drive Dihedral in the coordinate driving panel. The appropriate message from among the following will appear in the menu bar.

Drive Distance: Select 2 atoms or a bond.

or

Drive Angle: Select 3 atoms or 2 adjacent bonds.

or

Drive Dihedral: Select 4 atoms or 3 adjacent bonds.

These messages, as well as the overall procedure for identifying coordinates, are similar to those already discussed for entering constraints (see Sections 6.5 to 6.7). Compliance will result in display of another dialog (the distance dialog is illustrated).

This comprises four boxes, into which the initial (From) and final (To) values of the distance to be varied need to be entered, along with the number of steps (Steps) in the sequence. The last box (Sigma) is the weighting given to the penalty function for variations involving molecular mechanics and semi-empirical based energy functions only.

After the appropriate information has been entered, clicking on OK saves the information about the particular (distance, angle or dihedral angle) constraint in box at the center of the coordinate driving panel and removes the dialog from the screen. Clicking on Cancel removes the dialog without saving any information.

At this point, the user has three options:

  1. Select another geometrical variable to be varied in "lock step" with any previously defined variables. This is accomplished by clicking on Drive Distance, Drive Angle or Drive Dihedral, selecting the appropriate atoms and/or bonds to define the variable, specifying values for From, To and (optionally) Sigma and clicking on Save. Steps is fixed at the value defined for the first variable.

  2. Go to the second segment by clicking on "s" (the "up" arrow key to the right of Segment in the coordinate driving panel). A "2" will replace the "1". The box in the middle of the coordinate driving panel displaying information about the constraints will now be empty. (You can see the instructions for the first segment by clicking on "t".) Next, click on Drive Distance, Drive Angle or Drive Dihedral, select the appropriate atoms and/or bonds to define the variable, specify values for From, To, Steps, and (optionally) Sigma, and finally click on Save.

    It is intended that the individual segments in the overall sequence will "blend" with one another, providing the ability to represent a complex reaction pathway in a continuous way. This is entirely under the control of the user, and some effort may be needed to achieve the desired result.

  3. Quit the dialog by selecting Quit from the File menu.

The individual constraints may be altered or deleted altogether. A constraint may be altered by first clicking on its entry in the box inside the coordinate driving panel, at which time it will be highlighted (displayed in reverse video) and the information associated with the constraint (From, To, Steps and Sigma) displayed in the coordinate driving panel. This may then be modified. A constraint may be deleted by clicking on its entry, followed by clicking on Delete. Clicking on Delete without any constraints being identified, leads to a message in the menu bar.

Delete. Select Distance, Angle or Dihedral Icon

This requests that one of the constraint icons which appear on the structure model to be selected. This done, the constraint is deleted.

Coordinate driving may occur in the presence of constraints, provided that these constraints do not involve the variables being "driven". The selection of actually whether or not to use constraints is made in the setup dialogs for molecular mechanics, semi-empirical, density functional or ab initio calculations.


Section 7.5.1: Coordinate Driving Functionality

As in the builder dialogs, the molecule may be translated, rotated or scaled. Bond rotation and stretching are not permitted.


Section 7.5.2: Menus in the Coordinate Driving Dialog

Other functions are accessed by way of menus from the menu bar at the top of the Coordinate Driving dialog.


Section 7.5.2.1: Logo

Selection results in display of the following menu:

About SPARTAN
Colors
Preferences

About Spartan

Colors

Preferences

These are the same functions already described in Sections 3.1 and 3.3, although some functions do not apply to operations in the Coordinate Driving dialog.


Section 7.5.2.2: File

Selection results in display of the following menu:

Save
Save As

Quit Ctrl+Q

Save

Saves a previously named file. If Save is selected for an unnamed (not previously saved) molecule, it behaves as Save As (see Section 4.5). The screen is not cleared, and the Coordinate Driving dialog is not exited.

Save As

This is the same function already described in Section 4.5. The screen is not cleared, and the Coordinate Driving dialog is not exited.

Quit

Exits the Coordinate Driving dialog.


Section 7.5.2.3: Edit

Selection results in display of following menu:

Clear

Clear

Clears the existing structure from the screen. A warning message is first presented to the user.


Section 7.5.2.4: Geometry

Selection results in display of the following menu:

Distance
Angle
Dihedral

Define Point
Define Plane

Report Symmetry

Distance

Angle

Dihedral

Define Point

Define Plane

Report Symmetry

These are the same functions previously described in Sections 6.1 to 6.3 and 6.8, 6.9 and 6.12, respectively.


Section 7.5.2.5: Help

Selection results in display of the following menu:

Coordinate Driving Overview

Coordinate Driving Overview

Describes the operation of Spartan's Coordinate Driving procedure.


Section 7.6: Combinatorial Study

This allows a series of substituted molecules to be constructed from a parent structure. Substituents may be placed on one or more positions on the molecule and may either be drawn from a short library supplied with Spartan or be user defined. The result is a list presented in Spartan's spreadsheet.

Selection of Combinatorial Study from the Build menu results in a dialog.

The dialog is divided into two regions. The work area at the top displays the parent molecule (to be substituted), and identifies available attachment points (free valences). A different attachment point from that selected upon entry (indicated by a yellow circle) may be designated by clicking on it. The parent molecule may be manipulated (translated, rotated, scaled) in the usual manner.

The bottom of the dialog comprises a file browser on the left, from which substituents are selected, a viewport in the middle, to show the substituent and allow selection of its attachment point (free valence), and a listing of substituents which have already been selected.

Upon initial entry, the file browser is pointing to the directory "Combinatorial_Study". This contains a short list of common substituents. Other substituents may be accessed from the file browser in the usual way. As a shortcut, the path to the desired substituent directory may be entered directly into the box underneath the file browser.

The selected substituent appears in the viewport at the bottom (center) of the dialog. A different attachment point (free valence) from that selected (indicated by a yellow circle) may be designated by clicking on it. The substituent may be manipulated (translated, rotated, scaled) in the usual manner. The selected substituent is added from its designated free valence to the designated free valence of the parent molecule by clicking on Add. Following this, a number appears next to the free valence of the parent (in the work area) indicating the total number of substituents added thus far to this position. In addition, the name of the substituent will be entered into the substituent list at the bottom (far right) of the dialog. Other substituents can be added to the same position on the parent by selecting them from the file browser and clicking on Add. The number adjacent to the free valence on the parent will be incremented by one with each additional substituent.

A substituent may be removed by first selecting it in the substituent list (it will be highlighted) and then clicking on Remove. The number next to the free valence on the parent will be decremented by one.

Different attachment points on the parent molecule may be selected simply by clicking on the appropriate free valences, and the process of substituent selection repeated. It is not necessary to "fully substitute" one position of the parent before going on to the next position.

After all substituents have been added, the full list of substituted molecules is generated using Generate Monosubstituted or Generate Polysubstituted under the Edit menu (see below). The former builds molecules with only a
single substituent while the latter produces all combinations resulting from substitution of multiple positions. (The two modes are the same if only one position is substituted.)


Section 7.6.1: Combinatorial Study Functionality

As in the builder dialogs, both the parent molecule and the selected substituent may be translated, rotated or scaled using the mouse. Bond rotation is permitted once the list of substituted molecules has been generated (Generate Monosubstituted and Generate Polysubstituted under the Edit menu), but not prior to this. In conjuction with Clone (see below) this allows generation of more than one confomer for each substituted molecule. Bond stretching is not permitted.


Section 7.6.2: Menus in the Combinatorial Study Dialog

Other functions are accessed by way of menus from the menu bar at the top of the Combinatorial Study dialog.


Section 7.6.2.1: Logo

Selection results in display of the following menu:

About SPARTAN
Colors
Preferences

About Spartan

Colors

Preferences

These are the same functions already described in Sections 3.1 and 3.3, although some functions do not apply to operations in the Combinatorial Study dialog.


Section 7.6.2.2: File

7.6.2.2 File

Selection results in display of the following menu:

Save
Save As

Quit Ctrl+Q

Save

Saves a previously named file. The screen is not cleared, and the Combinatorial Study dialog is not exited. Save is available only following generation of a list of substituted molecules (Generate Monosubstituted or Generate Polysubstituted under the Edit menu).

Save As

This is the same function already described in Section 4.5. The screen is not cleared, and the Combinatorial Study dialog is not exited. Save As is available only following generation of a list of substituted molecules (Generate Monosubstituted or Generate Polysubstituted under the Edit menu).

Quit

Exits the Combinatorial Study dialog. If it is selecodî prior to list generation (Generate Monosubstituted or Generate Polysubstituted under the Edit menu), a warning message is presented warning that information relating to substitution will be lost.

If selected following list generation, it saves the list of substituted molecules prior to exiting the dialog.


Section 7.6.2.3: Edit

Selection results in display of following menu:

Generate Monosubstituted
Generate Polysubstituted

Clear

Generate Monosubstituted

Generates a list of monosubstituted molecules. Selection expands the work area to full screen and provides a dialog listing the substituted molecules (member1, member2, . . . ).

Individual entries are selected for display by clicking on their names in the dialog. The entries may also be accessed using the " " and " " keys at the bottom of the dialog, and be "animated" (stepped through in rapid succession) using Animate. Each entry may be manipulated (translated, rotated, scaled) in the usual manner. In addition, single bonds may be rotated about (combination of space bar and middle mouse button as in the builders). Thus, it is possible to change the conformation of the substituted molecule. It is also possible to extend the list with two (or more) different conformers for a particular molecule. To do this, select the appropriate substituted molecule, and click on Clone. This makes an identical copy of the selected molecule. Alter the conformation of either the original molecule or the "clone".

Molecules may be deleted from the list using Delete in the dialog; no warnings are provided.

Generate Polysubstituted

This is identical to Generate Monosubstituted except that polysubstituted molecules are produced. (If monosubstituted systems are also desired, it is necessary to explicitly include "hydrogen" in the substituent list for each attachment position on the parent. Hydrogen is a substituent in the library supplied with Spartan.)

Clear

Operation depends on whether a list of substituted molecules (Generate Monosubstituted or Generate Polysubstituted under the Edit menu) has been
generated. If a list has not been generated, clears information regarding to substitution. A warning message is first presented.

If a list has been generated, removes the list and reverts back to the situation prior to selection of Generate Monosubstituted or Generate Polysubstituted. A warning message is provided.


Section 7.6.2.4: Geometry

Selection results in display of the following menu:

Distance
Angle
Dihedral

Define Point
Define Plane

Report Symmetry

Distance

Angle

Dihedral

Define Point

Define Plane

Report Symmetry

These are the same functions previously described in Sections 6.1 to 6.3 and 6.8, 6.9 and 6.12, respectively.


Section 7.6.2.5: Help

Selection results in display of the following menu:

Combinatorial Study Overview

Combinatorial Study Overview

Describes the operation of Spartan's Combinatorial Study procedure.


Section 7.7: Isotopes

Allows default atomic masses to be replaced by alternative values. The primary use is in the calculation of vibrational frequencies and thermodynamic properties which depend on the frequencies, and for evaluation of thermodynamic and kinetic isotope effects. The following isotopic substitutions may be made (default isotope indicated in bold type):

1H, 2H, 3H; 6Li, 7Li; 10B, 11B; 12C, 13C, 14C; 14N,
15N; 24Mg, 25Mg, 26Mg; 28Si, 29Si, 30Si; 32S, 33S, 34S, 36S

Selection results in a message in the menu bar.

Isotopes: Select atom.

Clicking on an atom (from among the atoms listed above; other selections will result in a bell) designates it for isotopic substitution. The mass change is indicated on the structure display as well as a dialog at the top left of the screen.

Clicking again on the atom moves to the next available mass and finally back to the default mass. This sequence may be repeated for as many atoms as required. The dialog may be exited (with mass changes kept) by clicking on Save inside the dialog. The dialog may be exited without keeping the mass change by clicking on Cancel inside the dialog.


Questions, comments, or suggestions?
webmaster@wavefun.com

Copyright 1995-98 Wavefunction, Inc. All rights reserved